Difference between revisions of "Download"

From Syslinux Wiki
Jump to: navigation, search
m (Wiki formatting.)
m (Re-arrangement of paragraphs.)
Line 1: Line 1:
The latest official version of Syslinux can be downloaded in .tar.gz, .tar.bz2, .tar.xz, and .zip formats from [http://www.kernel.org/pub/linux/utils/boot/syslinux/ kernel.org]. This download includes both the source and official pre-compiled binaries that should work for most users (See also [[Common_Problems#Official_Binaries|Official Binaries]]). Version changes are available in the .LSM files.
+
Official Testing versions (aka pre-release), when available,
 +
can be downloaded from:
 +
https://www.kernel.org/pub/linux/utils/boot/syslinux/Testing/
 +
 
 +
The latest official version of Syslinux can be downloaded  
 +
in .tar.gz, .tar.bz2, .tar.xz, and .zip formats from  
 +
[https://www.kernel.org/pub/linux/utils/boot/syslinux/ kernel.org].  
 +
This download includes both the source and official pre-compiled binaries  
 +
that should work for most users  
 +
(See also [[Common_Problems#Official_Binaries|Official Binaries]]).  
 +
Version changes are available in the .LSM files.
  
 
The Syslinux download includes [[PXELINUX]], [[ISOLINUX]] and [[MEMDISK]] as well.
 
The Syslinux download includes [[PXELINUX]], [[ISOLINUX]] and [[MEMDISK]] as well.
  
Official Testing versions (aka pre-release), when available, can be downloaded from:
+
<!-- Official Testing versions (aka pre-release), when available, can be downloaded from: -->
  https://www.kernel.org/pub/linux/utils/boot/syslinux/Testing/  
+
<!-- https://www.kernel.org/pub/linux/utils/boot/syslinux/Testing/ -->
  
See also [[Development]] and [[Contact]].
+
See also [[Changelog]], [[Development]] and [[Contact]].
  
 
== WARNING ==
 
== WARNING ==
At least SuSE, Mandriva, and Ubuntu use a version of SYSLINUX modified with a patch called "gfxboot". This is a highly invasive and unsupported modification of SYSLINUX. Please avoid these versions if possible.
+
At least SuSE, Mandriva, and Ubuntu use a version of SYSLINUX modified with  
 +
a patch called "gfxboot".  
 +
This is a highly invasive and unsupported modification of SYSLINUX.  
 +
Please avoid these versions if possible.
  
 
=== Warning-Ubuntu-Update ===
 
=== Warning-Ubuntu-Update ===
As of 2010-10-19, Ubuntu 10.10 (Maverick Meerkat) uses Syslinux 4.01 with [[GFXBoot.c32]] (now officially included) and includes several special patches to allow gfxboot to use some configuration directives that were originally intended to be used only with the Simple Menu modules ([[menu.c32]]/vesamenu.c32). Some patches are upstreamed, but some of them might not.
+
As of 2010-10-19, Ubuntu 10.10 (Maverick Meerkat) uses Syslinux 4.01 with  
 +
[[GFXBoot.c32]] (now officially included) and includes several special patches  
 +
to allow gfxboot to use some configuration directives that were originally  
 +
intended to be used only with the Simple Menu modules ([[menu.c32]]/vesamenu.c32).  
 +
Some patches are upstreamed, but some of them might not.
  
 
== VCS ==
 
== VCS ==
 
Information about how to download from the Version Control System is in the [[Development]] page.
 
Information about how to download from the Version Control System is in the [[Development]] page.

Revision as of 15:40, 20 October 2018

Official Testing versions (aka pre-release), when available, can be downloaded from:

https://www.kernel.org/pub/linux/utils/boot/syslinux/Testing/ 

The latest official version of Syslinux can be downloaded in .tar.gz, .tar.bz2, .tar.xz, and .zip formats from kernel.org. This download includes both the source and official pre-compiled binaries that should work for most users (See also Official Binaries). Version changes are available in the .LSM files.

The Syslinux download includes PXELINUX, ISOLINUX and MEMDISK as well.


See also Changelog, Development and Contact.

WARNING

At least SuSE, Mandriva, and Ubuntu use a version of SYSLINUX modified with a patch called "gfxboot". This is a highly invasive and unsupported modification of SYSLINUX. Please avoid these versions if possible.

Warning-Ubuntu-Update

As of 2010-10-19, Ubuntu 10.10 (Maverick Meerkat) uses Syslinux 4.01 with GFXBoot.c32 (now officially included) and includes several special patches to allow gfxboot to use some configuration directives that were originally intended to be used only with the Simple Menu modules (menu.c32/vesamenu.c32). Some patches are upstreamed, but some of them might not.

VCS

Information about how to download from the Version Control System is in the Development page.